PRB DEPRECATED, SEE KB#5050** SalesCart Toolbar gives no action or error.

Article # 5001 Print Article Print Article

The information in this article applies to this particular SalesCart Product(s): 
STD, PRO, SQL, NET, X


SYMPTOMS
When selecting create New SalesCart or Add Product Link Icon from the SalesCart toolbar, nothing happens or the following error occurs: COM Add In Error: Object variable or With block variable not set SalesCartAddIn

CAUSE
This problem can occur when the SalesCart software is uninstalled/re-installed and during the process the SalesCartAddIn.dll might have been locked in the system.

RESOLUTION
DEPRECATED, SEE KB#5050
The following procedure must be completed EXACTLY as specified below. If any steps are skipped the procedure AND the toolbar will not work.
  1. Download the Remove Toolbar File.

  2. Extract RemoveToolBar.exe from the zip file and save it in the to the following location:

    C:\Temp

  3. Open Microsoft FrontPage.

  4. Go to Tools > Add-Ins > Highlight "SalesCartAddIn" and click Remove, click OK.

  5. Go to Tools > Add-Ins > Select Add > Browse to location where the file "SalesCartAddInRemove.dll" is located:

    • Any version of SalesCart for FrontPage 2002 or below:
      C:\Program Files\Microsoft Office\Templates\1033\Webs\
    • Any version of SalesCart for FrontPage 2003:
      C:\Program Files\Microsoft Office\Templates\1033\Webs11\
    • Directory name of different versions of SalesCart:
      • SalesCartPRO.wiz
      • SalesCartX.wiz
      • SalesCart.wiz
      • SalesCartNET.wiz
    • Select "SalesCartAddInRemove.dll" and click OK > click OK again.

  6. Go to Windows Start > Run > In the Open: field type the following:

    • C:\Temp\RemoveToolBar.exe
    • Click OK.

  7. In FrontPage go to Tools > Add-Ins > Highlight "SalesCartAddIn" and click Remove, click OK.

  8. Go to Tools > Add-Ins > Select Add > Browse to location where the file "SalesCartAddIn.dll" is located:

    • Any version of SalesCart for FrontPage 2002 or below:
      C:\Program Files\Microsoft Office\Templates\1033\Webs\
    • Any version of SalesCart for FrontPage 2003:
      C:\Program Files\Microsoft Office\Templates\1033\Webs11\
    • Directory name of different versions of SalesCart:
      • SalesCartPRO.wiz
      • SalesCartX.wiz
      • SalesCart.wiz
      • SalesCartNET.wiz
    • Select "SalesCartAddIn.dll" and click OK > click OK again.

  9. Toolbar will now be functional.

SUMMARY
DEPRECATED, SEE KB#5050. This problem can occur when SalesCart is un-installed and re-installed on numerous bases causing the toolbar not to work. The problem is applicable to all versions of Standard, PRO, NET, SQL and X.

STATUS
DEPRECATED, SEE KB#5050

REFERENCE
KB 5050


Additional Query Words: toolbar,com,add-in,no action,

Active/inactive: Inactive
Author:
 WS
Date:
 06/24/04 Updated 06/22/05


* If you have an older version of SalesCart Standard, PRO, SQL and didn't find what you are looking for try the FAQ's archive. Click here!


ComCity® and SalesCart™ are trademarks of ComCity LLC. All other products mentioned are registered trademarks or trademarks of their respective companies.
Copyright © 1995-2014 ComCity LLC. All rights reserved.
  Last modified: Thursday May 29, 2014